import re
regex = re.compile(r"(<[^<>]*?ww3______sinaimg______cn[^<>]*?\/\s*?>|<a[^<>]*?ww3______sinaimg______cn.+?>.+?<\/a>)")
test_str = ("<img src=' ' onclick=\"window.open ('http://www.viidii.info/?http://ww3______sinaimg______cn/large/bd698b0fjw1ev9gjrevg2g20a505pu0x______gif&z'); />\n\n"
"<a href=\"ww3______sinaimg______cn\" > aaa</a>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")