package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<[^<>]*?ww3______sinaimg______cn[^<>]*?\/\s*?>|<a[^<>]*?ww3______sinaimg______cn.+?>.+?<\/a>)`)
var str = `<img src=' ' onclick="window.open ('http://www.viidii.info/?http://ww3______sinaimg______cn/large/bd698b0fjw1ev9gjrevg2g20a505pu0x______gif&z'); />
<a href="ww3______sinaimg______cn" > aaa</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}