import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[^<>]*?ww3______sinaimg______cn[^<>]*?\\/\\s*?>|<a[^<>]*?ww3______sinaimg______cn.+?>.+?<\\/a>)";
final String string = "<img src=' ' onclick=\"window.open ('http://www.viidii.info/?http://ww3______sinaimg______cn/large/bd698b0fjw1ev9gjrevg2g20a505pu0x______gif&z'); />\n\n"
+ "<a href=\"ww3______sinaimg______cn\" > aaa</a>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}