# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:'|\s?\b\w+\b\s?)(?!'s)//g;t' <<< "Watch Sidney's video "