const regex = /(?:'|\s?\b\w+\b\s?)(?!'s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\'|\\s?\\b\\w+\\b\\s?)(?!\'s)', 'g')
const str = `Watch Sidney's video `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);