use strict;
my $str = 'Watch Sidney\'s video ';
my $regex = qr/(?:'|\s?\b\w+\b\s?)(?!'s)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";