$re = '/(?:\'|\s?\b\w+\b\s?)(?!\'s)/';
$str = 'Watch Sidney\'s video ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;