re = /(?:'|\s?\b\w+\b\s?)(?!'s)/
str = 'Watch Sidney\'s video '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result