# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Keyword(?=[^><]*<\\/p>)/<em>$0<\/em>/gs;t' <<< "<div>
<img />
<span>Foo Bar - Keyword</span>
</div>
<h2>Keyword - Foo Bar</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
<h2>Heading - Keyword</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
..."