using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Keyword(?=[^><]*<\/p>)";
string substitution = @"<em>$0</em>";
string input = @"<div>
<img />
<span>Foo Bar - Keyword</span>
</div>
<h2>Keyword - Foo Bar</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
<h2>Heading - Keyword</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
...";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}