# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Keyword(?=[^><]*<\/p>)"
test_str = ("<div>\n"
" <img />\n"
" <span>Foo Bar - Keyword</span>\n"
" </div>\n"
" <h2>Keyword - Foo Bar</h2>\n"
" <p>Lorem Ypsum, Keyword, Lorem Pysum.</p>\n"
" <h2>Heading - Keyword</h2>\n"
" <p>Lorem Ypsum, Keyword, Lorem Pysum.</p>\n"
" ...")
subst = "<em>$0</em>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.