#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)Keyword(?=[^><]*<\/p>)"
Local $sString = "<div>" & @CRLF & _
" <img />" & @CRLF & _
" <span>Foo Bar - Keyword</span>" & @CRLF & _
" </div>" & @CRLF & _
" <h2>Keyword - Foo Bar</h2>" & @CRLF & _
" <p>Lorem Ypsum, Keyword, Lorem Pysum.</p>" & @CRLF & _
" <h2>Heading - Keyword</h2>" & @CRLF & _
" <p>Lorem Ypsum, Keyword, Lorem Pysum.</p>" & @CRLF & _
" ..."
Local $sSubst = "<em>$0</em>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)