use strict;
my $str = '<div>
<img />
<span>Foo Bar - Keyword</span>
</div>
<h2>Keyword - Foo Bar</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
<h2>Heading - Keyword</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
...';
my $regex = qr/Keyword(?=[^><]*<\/p>)/sp;
my $subst = '<em>$0</em>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";