$re = '/Keyword(?=[^><]*<\/p>)/s';
$str = '<div>
<img />
<span>Foo Bar - Keyword</span>
</div>
<h2>Keyword - Foo Bar</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
<h2>Heading - Keyword</h2>
<p>Lorem Ypsum, Keyword, Lorem Pysum.</p>
...';
$subst = "<em>$0</em>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;