#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{([^{}]*)\|album}"
Local $sString = "{beethoven|artist}'s {piano sonata number twenty-three|track}" & @CRLF & _
"" & @CRLF & _
"{bach|artist}'s {cello preludes|track}" & @CRLF & _
"" & @CRLF & _
"{beethoven|artist}'s {opus fifty-seven sonata|track}" & @CRLF & _
"" & @CRLF & _
"{bach|artist}'s {cello preludes|track} performed by {yo-yo ma|artist}" & @CRLF & _
"" & @CRLF & _
"{Bulgarian womens choir|album} "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")