re = /{([^{}]*)\|album}/
str = '{beethoven|artist}\'s {piano sonata number twenty-three|track}
{bach|artist}\'s {cello preludes|track}
{beethoven|artist}\'s {opus fifty-seven sonata|track}
{bach|artist}\'s {cello preludes|track} performed by {yo-yo ma|artist}
{Bulgarian womens choir|album} '
# Print the match result
str.match(re) do |match|
puts match.to_s
end