using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{([^{}]*)\|album}";
string input = @"{beethoven|artist}'s {piano sonata number twenty-three|track}
{bach|artist}'s {cello preludes|track}
{beethoven|artist}'s {opus fifty-seven sonata|track}
{bach|artist}'s {cello preludes|track} performed by {yo-yo ma|artist}
{Bulgarian womens choir|album} ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}