package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{([^{}]*)\|album}`)
var str = `{beethoven|artist}'s {piano sonata number twenty-three|track}
{bach|artist}'s {cello preludes|track}
{beethoven|artist}'s {opus fifty-seven sonata|track}
{bach|artist}'s {cello preludes|track} performed by {yo-yo ma|artist}
{Bulgarian womens choir|album} `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}