#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ";(?!.*\)|\()"
Local $sString = "echo "Olá, mundo!";" & @CRLF & _
"echo "Aqui é outro bloco!";" & @CRLF & _
"def MeuTeste = "24055";" & @CRLF & _
"if 123 = 123 (echo "Executa isso!"; echo "isso também!";);" & @CRLF & _
"if 123 = 545 (echo "Não execute isso!"; echo "ignore isso!";);" & @CRLF & _
"pause;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")