re = /;(?!.*\)|\()/
str = 'echo "Olá, mundo!";
echo "Aqui é outro bloco!";
def MeuTeste = "24055";
if 123 = 123 (echo "Executa isso!"; echo "isso também!";);
if 123 = 545 (echo "Não execute isso!"; echo "ignore isso!";);
pause;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end