import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";(?!.*\\)|\\()";
final String string = "echo \"Olá, mundo!\";\n"
+ "echo \"Aqui é outro bloco!\";\n"
+ "def MeuTeste = \"24055\";\n"
+ "if 123 = 123 (echo \"Executa isso!\"; echo \"isso também!\";);\n"
+ "if 123 = 545 (echo \"Não execute isso!\"; echo \"ignore isso!\";);\n"
+ "pause;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}