const regex = /;(?!.*\)|\()/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(';(?!.*\\)|\\()', 'g')
const str = `echo "Olá, mundo!";
echo "Aqui é outro bloco!";
def MeuTeste = "24055";
if 123 = 123 (echo "Executa isso!"; echo "isso também!";);
if 123 = 545 (echo "Não execute isso!"; echo "ignore isso!";);
pause;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}