$re = '/;(?!.*\)|\()/';
$str = 'echo "Olá, mundo!";
echo "Aqui é outro bloco!";
def MeuTeste = "24055";
if 123 = 123 (echo "Executa isso!"; echo "isso também!";);
if 123 = 545 (echo "Não execute isso!"; echo "ignore isso!";);
pause;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);