using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";(?!.*\)|\()";
string input = @"echo ""Olá, mundo!"";
echo ""Aqui é outro bloco!"";
def MeuTeste = ""24055"";
if 123 = 123 (echo ""Executa isso!""; echo ""isso também!"";);
if 123 = 545 (echo ""Não execute isso!""; echo ""ignore isso!"";);
pause;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}