#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<p>((?=[^.])(?:.(?!\.))*?)<\/p>"
Local $sString = "<p>.</p>" & @CRLF & _
"<p>Sentence.</p><p>Title</p><p>Sentence.</p>" & @CRLF & _
"<p>Title</p>" & @CRLF & _
"<p>Sentence.</p>"
Local $sSubst = "<h3>$1</h3>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)