import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>((?=[^.])(?:.(?!\\.))*?)<\\/p>";
final String string = "<p>.</p>\n"
+ "<p>Sentence.</p><p>Title</p><p>Sentence.</p>\n"
+ "<p>Title</p>\n"
+ "<p>Sentence.</p>";
final String subst = "<h3>$1</h3>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}