$re = '/<p>((?=[^.])(?:.(?!\.))*?)<\/p>/i';
$str = '<p>.</p>
<p>Sentence.</p><p>Title</p><p>Sentence.</p>
<p>Title</p>
<p>Sentence.</p>';
$subst = "<h3>$1</h3>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;