const regex = /<p>((?=[^.])(?:.(?!\.))*?)<\/p>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>((?=[^.])(?:.(?!\\.))*?)<\\\/p>', 'gi')
const str = `<p>.</p>
<p>Sentence.</p><p>Title</p><p>Sentence.</p>
<p>Title</p>
<p>Sentence.</p>`;
const subst = `<h3>$1</h3>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);