re = /<p>((?=[^.])(?:.(?!\.))*?)<\/p>/i
str = '<p>.</p>
<p>Sentence.</p><p>Title</p><p>Sentence.</p>
<p>Title</p>
<p>Sentence.</p>'
subst = '<h3>$1</h3>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result