import Foundation
let pattern = #"<p>((?=[^.])(?:.(?!\.))*?)<\/p>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<p>.</p>
<p>Sentence.</p><p>Title</p><p>Sentence.</p>
<p>Title</p>
<p>Sentence.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<h3>$1</h3>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)