#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?(DEFINE)" & @CRLF & _
" (?<item>\s*(?:(?&curly)|(?&square))|[^\[\{]*)" & @CRLF & _
" (?<attr>\s+\w+="[^"]*")" & @CRLF & _
" (?<curly>\{(\w+)(?&attr)*\}(?&item)*\{\/\w+\})" & @CRLF & _
" (?<square>\[(\w+)(?&attr)*\](?&item)*\[\/\w+\])" & @CRLF & _
")\[tab(?&attr)*\](?&item)*\[\/tab\]"
Local $sString = "{jmstabs type="horizontal" theme="two" nav="left"}" & @CRLF & _
" [tab title="Tab title 1"]Tab content 1[/tab]" & @CRLF & _
" [tab title="Tab title 2"]Tab content 2[/tab]" & @CRLF & _
" [tab title="Tab title 3"]" & @CRLF & _
" {jmstabs}" & @CRLF & _
" [tab title="Tab child 1"]Tab child 1[/tab]" & @CRLF & _
" [tab title="Tab child 2"]Tab child 2[/tab]" & @CRLF & _
" {/jmstabs}" & @CRLF & _
" [/tab]" & @CRLF & _
"{/jmstabs}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")