const regex = /(?(DEFINE)
(?<item>\s*(?:(?&curly)|(?&square))|[^\[\{]*)
(?<attr>\s+\w+="[^"]*")
(?<curly>\{(\w+)(?&attr)*\}(?&item)*\{\/\w+\})
(?<square>\[(\w+)(?&attr)*\](?&item)*\[\/\w+\])
)\[tab(?&attr)*\](?&item)*\[\/tab\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<item>\\s*(?:(?&curly)|(?&square))|[^\\[\\{]*)
(?<attr>\\s+\\w+="[^"]*")
(?<curly>\\{(\\w+)(?&attr)*\\}(?&item)*\\{\\\/\\w+\\})
(?<square>\\[(\\w+)(?&attr)*\\](?&item)*\\[\\\/\\w+\\])
)\\[tab(?&attr)*\\](?&item)*\\[\\\/tab\\]', 'g')
const str = `{jmstabs type="horizontal" theme="two" nav="left"}
[tab title="Tab title 1"]Tab content 1[/tab]
[tab title="Tab title 2"]Tab content 2[/tab]
[tab title="Tab title 3"]
{jmstabs}
[tab title="Tab child 1"]Tab child 1[/tab]
[tab title="Tab child 2"]Tab child 2[/tab]
{/jmstabs}
[/tab]
{/jmstabs}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}