# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?(DEFINE)\n"
r" (?<item>\s*(?:(?&curly)|(?&square))|[^\[\{]*)\n"
r" (?<attr>\s+\w+=\"[^\"]*\")\n"
r" (?<curly>\{(\w+)(?&attr)*\}(?&item)*\{\/\w+\})\n"
r" (?<square>\[(\w+)(?&attr)*\](?&item)*\[\/\w+\])\n"
r")\[tab(?&attr)*\](?&item)*\[\/tab\]")
test_str = ("{jmstabs type=\"horizontal\" theme=\"two\" nav=\"left\"}\n"
" [tab title=\"Tab title 1\"]Tab content 1[/tab]\n"
" [tab title=\"Tab title 2\"]Tab content 2[/tab]\n"
" [tab title=\"Tab title 3\"]\n"
" {jmstabs}\n"
" [tab title=\"Tab child 1\"]Tab child 1[/tab]\n"
" [tab title=\"Tab child 2\"]Tab child 2[/tab]\n"
" {/jmstabs}\n"
" [/tab]\n"
"{/jmstabs}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.