// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?(DEFINE)
(?<item>\s*(?:(?&curly)|(?&square))|[^\[\{]*)
(?<attr>\s+\w+="[^"]*")
(?<curly>\{(\w+)(?&attr)*\}(?&item)*\{\/\w+\})
(?<square>\[(\w+)(?&attr)*\](?&item)*\[\/\w+\])
)\[tab(?&attr)*\](?&item)*\[\/tab\]"#).unwrap();
let string = "{jmstabs type=\"horizontal\" theme=\"two\" nav=\"left\"}
[tab title=\"Tab title 1\"]Tab content 1[/tab]
[tab title=\"Tab title 2\"]Tab content 2[/tab]
[tab title=\"Tab title 3\"]
{jmstabs}
[tab title=\"Tab child 1\"]Tab child 1[/tab]
[tab title=\"Tab child 2\"]Tab child 2[/tab]
{/jmstabs}
[/tab]
{/jmstabs}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}