import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<item>\\s*(?:(?&curly)|(?&square))|[^\\[\\{]*)\n"
+ " (?<attr>\\s+\\w+=\"[^\"]*\")\n"
+ " (?<curly>\\{(\\w+)(?&attr)*\\}(?&item)*\\{\\/\\w+\\})\n"
+ " (?<square>\\[(\\w+)(?&attr)*\\](?&item)*\\[\\/\\w+\\])\n"
+ ")\\[tab(?&attr)*\\](?&item)*\\[\\/tab\\]";
final String string = "{jmstabs type=\"horizontal\" theme=\"two\" nav=\"left\"}\n"
+ " [tab title=\"Tab title 1\"]Tab content 1[/tab]\n"
+ " [tab title=\"Tab title 2\"]Tab content 2[/tab]\n"
+ " [tab title=\"Tab title 3\"]\n"
+ " {jmstabs}\n"
+ " [tab title=\"Tab child 1\"]Tab child 1[/tab]\n"
+ " [tab title=\"Tab child 2\"]Tab child 2[/tab]\n"
+ " {/jmstabs}\n"
+ " [/tab]\n"
+ "{/jmstabs}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}