$re = '/(?(DEFINE)
(?<item>\s*(?:(?&curly)|(?&square))|[^\[\{]*)
(?<attr>\s+\w+="[^"]*")
(?<curly>\{(\w+)(?&attr)*\}(?&item)*\{\/\w+\})
(?<square>\[(\w+)(?&attr)*\](?&item)*\[\/\w+\])
)\[tab(?&attr)*\](?&item)*\[\/tab\]/';
$str = '{jmstabs type="horizontal" theme="two" nav="left"}
[tab title="Tab title 1"]Tab content 1[/tab]
[tab title="Tab title 2"]Tab content 2[/tab]
[tab title="Tab title 3"]
{jmstabs}
[tab title="Tab child 1"]Tab child 1[/tab]
[tab title="Tab child 2"]Tab child 2[/tab]
{/jmstabs}
[/tab]
{/jmstabs}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);