#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\W(\d{3})?\W?(\d{4})\W?(\d{4})\W"
Local $sString = "Mi nombre es Rodrigo Polo y mi telefono es +502 5587-1153 o tambien el (502) 5587-1153 o el 502-55871152 o el 55871153 o el (502) 55871153 o 50255871153 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")