package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\W(\d{3})?\W?(\d{4})\W?(\d{4})\W`)
var str = `Mi nombre es Rodrigo Polo y mi telefono es +502 5587-1153 o tambien el (502) 5587-1153 o el 502-55871152 o el 55871153 o el (502) 55871153 o 50255871153 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}