const regex = /\W(\d{3})?\W?(\d{4})\W?(\d{4})\W/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W(\\d{3})?\\W?(\\d{4})\\W?(\\d{4})\\W', 'g')
const str = `Mi nombre es Rodrigo Polo y mi telefono es +502 5587-1153 o tambien el (502) 5587-1153 o el 502-55871152 o el 55871153 o el (502) 55871153 o 50255871153 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}