# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\p{Cc}\d\p{P}\s„““”"]+//gu;t' <<< "\"Some string\""