using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\p{Cc}\d\p{P}\s„““”""]+";
string substitution = @"";
string input = @"""Some string""";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}