$re = '/[\p{Cc}\d\p{P}\sāāāā"]+/u';
$str = '"Some string"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;