#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "From:\s{0,10}"[\w.+\s\-]{0,25}"\s{0,1}\W[\w.+\-]{0,25}@mydomain\.com\W"
Local $sString = "From: "Employee Name" <employeename@mydomain.com>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")