import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "From:\\s{0,10}\"[\\w.+\\s\\-]{0,25}\"\\s{0,1}\\W[\\w.+\\-]{0,25}@mydomain\\.com\\W";
final String string = "From: \"Employee Name\" <employeename@mydomain.com>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}