using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From:\s{0,10}""[\w.+\s\-]{0,25}""\s{0,1}\W[\w.+\-]{0,25}@mydomain\.com\W";
string input = @"From: ""Employee Name"" <employeename@mydomain.com>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}