const regex = /From:\s{0,10}"[\w.+\s\-]{0,25}"\s{0,1}\W[\w.+\-]{0,25}@mydomain\.com\W/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('From:\\s{0,10}"[\\w.+\\s\\-]{0,25}"\\s{0,1}\\W[\\w.+\\-]{0,25}@mydomain\\.com\\W', '')
const str = `From: "Employee Name" <employeename@mydomain.com>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}