import Foundation
let pattern = #"From:\s{0,10}"[\w.+\s\-]{0,25}"\s{0,1}\W[\w.+\-]{0,25}@mydomain\.com\W"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"From: "Employee Name" <employeename@mydomain.com>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}