#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxJs)(?<link_all>" & @CRLF & _
" (?<!\\)\[" & @CRLF & _
" (?<link_name>" & @CRLF & _
" (?>\\[\[\]]|[^\[\]])*+" & @CRLF & _
" )" & @CRLF & _
" (?<!\\)\]" & @CRLF & _
" (?:" & @CRLF & _
" (?:" & @CRLF & _
" [ ]?" & @CRLF & _
" (?:\n[ ]*)?" & @CRLF & _
" (?<!\\)\[(?<link_id>.*?)(?<!\\)\]" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" (?<!\\)\(" & @CRLF & _
" [ \t]*" & @CRLF & _
" (?:" & @CRLF & _
" <(?<link_url>.*?)>" & @CRLF & _
" |" & @CRLF & _
" (?<link_url>.*?)" & @CRLF & _
" )" & @CRLF & _
" [ \t]*" & @CRLF & _
" (?:" & @CRLF & _
" (?<link_title_container>['"])" & @CRLF & _
" (?<link_title>.*?)" & @CRLF & _
" \g{link_title_container}" & @CRLF & _
" )?" & @CRLF & _
" (?<!\\)\)" & @CRLF & _
" (?![[:blank:]\h]+["'][^"']+["'])" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
")"
Local $sString = "[Inline link 3 with non-escaped parens](/url(test) "title")" & @CRLF & _
"" & @CRLF & _
"Foo [bar]" & @CRLF & _
"" & @CRLF & _
"This one has a [line" & @CRLF & _
"break][]." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")