const regex = /(?<link_all>
(?<!\\)\[
(?<link_name>
(?>\\[\[\]]|[^\[\]])*+
)
(?<!\\)\]
(?:
(?:
[ ]?
(?:\n[ ]*)?
(?<!\\)\[(?<link_id>.*?)(?<!\\)\]
)
|
(?:
(?<!\\)\(
[ \t]*
(?:
<(?<link_url>.*?)>
|
(?<link_url>.*?)
)
[ \t]*
(?:
(?<link_title_container>['"])
(?<link_title>.*?)
\g{link_title_container}
)?
(?<!\\)\)
(?![[:blank:]\h]+["'][^"']+["'])
)
)
)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<link_all>
(?<!\\\\)\\[
(?<link_name>
(?>\\\\[\\[\\]]|[^\\[\\]])*+
)
(?<!\\\\)\\]
(?:
(?:
[ ]?
(?:\\n[ ]*)?
(?<!\\\\)\\[(?<link_id>.*?)(?<!\\\\)\\]
)
|
(?:
(?<!\\\\)\\(
[ \\t]*
(?:
<(?<link_url>.*?)>
|
(?<link_url>.*?)
)
[ \\t]*
(?:
(?<link_title_container>[\'"])
(?<link_title>.*?)
\\g{link_title_container}
)?
(?<!\\\\)\\)
(?![[:blank:]\\h]+["\'][^"\']+["\'])
)
)
)', 'gms')
const str = `[Inline link 3 with non-escaped parens](/url(test) "title")
Foo [bar]
This one has a [line
break][].
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}