import Foundation
// WARNING: You included a flag that Swift doesn't support: J
// Wehn this flag is set, it allows duplicated capturing group names.
// By default, Swift captures only the last value matched for a repeated capture group.
// As an alternative, the pattern can be modified to contain one capturing group per group you want to get in the result.
let pattern = #"""
(?<link_all>
(?<!\\)\[
(?<link_name>
(?>\\[\[\]]|[^\[\]])*+
)
(?<!\\)\]
(?:
(?:
[ ]?
(?:\n[ ]*)?
(?<!\\)\[(?<link_id>.*?)(?<!\\)\]
)
|
(?:
(?<!\\)\(
[ \t]*
(?:
<(?<link_url>.*?)>
|
(?<link_url>.*?)
)
[ \t]*
(?:
(?<link_title_container>['"])
(?<link_title>.*?)
\g{link_title_container}
)?
(?<!\\)\)
(?![[:blank:]\h]+["'][^"']+["'])
)
)
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
[Inline link 3 with non-escaped parens](/url(test) "title")
Foo [bar]
This one has a [line
break][].
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)